Monday, 21 December 2015

Running AX7 VM on Oracle VirtualBox

In my previous post I described how to obtain the VM for AX7 CTP8. To run this VM you do not have to use Hyper V, VirtualBox works perfectly as well. In today's post I'll outline the steps required to run this VM in the VirtualBox.

Once you have downloaded the VM (20 files of almost 20 GB size), double click on the first file.


This will ask you the folder where to extract the files. Choose a folder and click Extract. Make sure that the drive where you are extracting the files have at least 120 GB space. More space will be required if you want to save the state of the machine instead of turning it off every time.


This step will take a while depending on your hardware capabilities. Once done you'll have a single VHD file.


Open VirtualBox and click on New button.


Name the virtual machine and choose windows OS as shown below.


Click on Next and choose RAM. MS recommends having a VM of at least 16 GB RAM. In my test machine I could only give it 6 GB, it was slow but not very slow.


Click Next and choose the extracted VHD,


Clicking on Create will create the VM. Before starting the VM, click on the Settings and change the number of CPUs as shown below. More CPU the better it will be.


The network on a VirtualBox VM is by default configured using NAT as shown below so no special setup is required here.


Now the VM can be started. Once started, on the the login page you'll see the familiar Windows 2012 credentials screen. The famous MS password for the VM Administrator account can be used to login.


Once logged in, open IE and click in the address bar. Here the AX7 link should automatically appear (highlighted below) as it was used previously when MS created the VM.


Once clicked, it will navigate to the Sign in page.


The password for this is mentioned on the AX 7 Sign Up page on Customer/Partner source. After entering the password, AX 7 opens up.


As my test machine was not very powerful, I initially got an error (I assume not everything was started), however after some time when I came back to this page and refreshed it, it worked fine.

This posting is provided "AS IS" with no warranties. Use code at your own risk.

17 comments:

  1. Navid, could not login to website, "You are not authorized to login with your current credentials..."...any suggestion?
    Chirag

    ReplyDelete
  2. Chirag, The password for login to the website is different from the one to login to the VM. The password is specified in the Customer/Partner Source AX 7 sign up page.

    ReplyDelete
  3. Hi Navid,
    I got this error message when I tried to login to the website, "There is a problem with the server. Sorry, the server has encountered an error. It is either not available or it can't respond at this time. Please contact your system administrator. 500 Error."
    What could be the issue?
    Thanks!
    Jasmine

    ReplyDelete
    Replies
    1. Hi
      You might also try to change Network settings on your VM "Attached to" from NAT to Bridget Adapter - helped in case. Idea taken from http://shankardynamicsax.blogspot.com/

      Delete
  4. Jasmine, If the error appears after you login to AX7, it might be due to some services still starting. Please give it some time and the error should go away. I experienced the same situation first time I started the VM as mentioned in the last paragraph of the post. Now I just suspend (save state) of VM instead of shutting down.

    ReplyDelete
  5. Getting same 500Error, anyone have resolve this issue, tried lot of things but no reolution,plz help

    ReplyDelete
  6. Getting the same error (There is a problem with the server. Sorry, the server has encountered an error. It is either not available or it can't respond at this time. Please contact your system administrator. 500 Error.).
    Waiting for Services to be started doesn't solve the Problem for me.
    Anyone else got a solution so far?

    ReplyDelete
  7. Multiple time i have extracted and multiple time i have setup fresh VM using virtual box but always same issue , anyone found the proper solution plz help (500 Error)

    ReplyDelete
  8. It was working for me the first times I tried it yesterday, but today I'm getting the same error: "Sorry, the server has encountered an error. It is either not available or it can't respond at this time. 500 error".
    Any ideas?
    Thanks.

    ReplyDelete
  9. yes There can be lot of issues related referred ddls, And the problem can not find and put dlls manually in a single day because all paths of dlls referring from config files.
    I have checked and find some ddl related issues like some ddl referd in config but missing from bin.
    For me Error:-
    Could not load file or assembaly 'Microsoft.Synamics.Ax.AosConfig'

    And if you want to check atr your end why the issue is coming, go on the approot
    and open Web.config file in notepad or in VS
    And comment complete httpErrors secton () and do Ctrl+F5 in browser, the actual issue will be display,
    And try to resolve

    ReplyDelete
  10. I got the above issue i.e., http error 500.
    Found issue is with the Date & Time settings in VM.
    Time zone, Date & Time should be the same like local system.
    After changing the settings, I can able to get in to the application without error.

    Regards,
    Shankar

    ReplyDelete
    Replies
    1. Thnx Shankar. It worked for me too...

      Delete
    2. Thanks Shankar,

      this was the solution for me too. Now it works

      Delete
  11. Hi,

    I have downloaded CTP8 and it was working fine for weeks until today when I tried to login using the standard login administrator@contosoax7.onmicrosoft.com and the standard password, but I am getting the error message "Your account is temporarily locked to prevent unauthorized user. Try again later, and if you still have trouble, contact your support person". Does anybody know how to get around it. I don't think I have tried with incorrect pwd that could cause this. Thanks.

    ReplyDelete
  12. followed the step by step several times. but never worked for me. it always gives this error..

    Your account is temporarily locked to prevent unauthorized use. Try again later, and if you still have trouble, contact your support person.

    Iam using administrator@contosoax7.onmicrosoft.com

















    Microsoft Dynamics ERP


    I have tried several times but never worked for me.



    Your account is temporarily locked to prevent unauthorized use. Try again later, and if you still have trouble, contact your support person.

    ReplyDelete
  13. I am also facing the same issue: "Account is temporarily locked". It has been working fine for Months, but suddenly the account was locked. Not sure what caused this and not sure of the resolution! Any help would be greatly appreciated.

    ReplyDelete
  14. Hi All,

    I have written another post to address the VM AX7 instance access issue. The post can be accessed from the following link

    http://axbytes.blogspot.co.uk/2016/02/error-when-accessing-ax7-vm.html

    ReplyDelete